This is an issue that I've run into frequently when setting up NLB clusters on virtual servers. Here are a couple of links regarding the issue. When setting up NLB clusters, use multicast mode and setup a static ARP entry.

http://kb.vmware.com/selfservice/mic...rnalId=1006525

http://blogs.technet.com/b/nettracer...e-subnets.aspx