Results 1 to 9 of 9
  1. Exclamation Help, need some experts, XenServer crashed

    Hi folks,
    hope you can help me out.
    This is the scenario iīm looking at right now.
    Small company running one xen server 5.6 FP1 (named "Xen-Server-1") in one pool (named DBS).
    The server uses an SR on a NAS (shared folder), which worked okay so far.
    Today the server crashed and i was asked for help.
    Iīm pretty much a newbie to Xen Server.
    I was told, there is no Server backup of Xen-Server-1, only a backup of the VMīs metadata, which is located in another shared folder on the NAS.
    I installed a new Xen Server on a new machine (named Xen-Server-2).
    Now iīm not quite sure how to get the existing VMīs from Server-1 running.

    My idea:
    Attaching the existing SR on the NAS to Xen-Server-2, attach the shared folder with the metadata to Server-2, restore the VMīs metadata to Server-2 and i should be ready to go, right?

    Please, i would be thankful for some advice how to deal with that, without "killing" the existing machines.

    Thanks for your help in advance.


  2. #2


    The metadata by itself won't help you. You need the VM files from the old XenServer as well. What cause the server to crash? What is the raid setup on the old server, and can you get access to the old drive?
    Brian Welchel

  3. Default more informations

    Quote Originally Posted by Brian View Post
    The metadata by itself won't help you. You need the VM files from the old XenServer as well. What cause the server to crash? What is the raid setup on the old server, and can you get access to the old drive?
    Hi Brian and thanks for your reply.
    Here are more infos.
    The server crashed due to hardware failure. It won't even show the boot screen on a reboot. Let' s assume it is toast and there is no chance to recover the hard disks.
    The SR is located on a Nas as well as the meta data. Unfotunatly i tried a restore this morning and accidentally did a new meta data backup from the new server (w/o) any vm running. Looks like the old meta files are overwritten with the new backup. All vm files are still okay. My point of view: allthe old disks should be still available. Is there a chsnce to "introduce" the existing virtual hd to a new vm or reattach it to the sr of the new server?
    Thanks for your help in advance

  4. #4


    Yes, that is definitely feasible. As long as the VM files are on the SR, you can create new VMs, attach the drives, and boot them to see which server is which, and name them accordingly. The metadata only saves the VM properties such as memory, which disk is assigned, network interfaces, etc.
    Brian Welchel

  5. Default

    Happy camper!
    Good morning Brian,
    after attaching the old SR to the new server, i "found" the virtual disks. Without description but weīre talking about 2 vms with different disk size.
    So i created the new vms, attached the appropriate vd and ....... it worked.
    The only "mistake", i used a WS2K3 template for a WS2K8 os. Hope that wonīt affect anything. But so far it runs with no problems.

    Thanks a lot for your help, espacially the offer to give me a kind of 101 tutorial.


  6. #6


    The template won't really matter, but you could always detach the disk and reattach to a new template. I'm glad everything worked out.
    Brian Welchel

  7. Default

    Hi folks, hi Brian,
    if you are still available.
    Checked the VMīs today and was wondering why xenCenter didnīt switch to rdp guest console automaticly.
    So obviously my "workaround" to get the vmīs running again worked kinda half way.
    With one vm ws2k8 i can ping the intranet ( i can ping the vm within the intranet as well), but i didnīt get connection to the internet.
    With the other vm i canīt even ping the intranet.
    Might there be a problem with "legacy" nicīs that might be floating around on the vmīs?

    WS2k8 asked me to run a new activation due to hardware changes. So something must have been changed.
    Help would be (again) much appreciated.


  8. #8


    Did you use the same version of XenServer on both hosts? Do you recall how the networking was setup on the old host (NIC bonds, VLANs, etc)?
    Brian Welchel

  9. Default

    Hi Brian,
    itīs the same version on both xen servers.
    I did a straight plain networking, no bonds or Vlans whatīs so ever. Both machines where available on the intranet with an ip-adress within the intranet range.
    I used only one physical nic on the old and on the new server as well as only one virtual nic on the vmīs. Worked on the old server but not on the new.
    Right now the state is:
    VM WS2K8 is reachable within (ping from and to)the intranet but not over the internet.
    VM XP SP3 gets out to the internet and the intranet, but thereīs no ping possible from the intranet to the VM.
    Strange behavior from my point of view.
    Right now i canīt access the xen server, but this afternoon i can get some screen shot and attache them to a post. Maybe that helps.
    Any specific informations you would like to see (log files for example) ?

    Thanks in advance

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts